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A. TUJUAN 

Memberikan informasi bagaimana melakukan uji pentautan molekular (molecular docking) menggunakan 
aplikasi PLANTS dan MOE.  

 
B. PENDAHULUAN  

 
 
 

C. OPERASIONAL 
C.1. Molecular Docking menggunakan PLANTS 

1. Alat & Instrumen: 

• Laptop atau Komputer  

• Aplikasi Marvin Sketch, Yasara, dan Virtualbox  
 

2. Bahan: 

• Protein target (kode protein dari PDB) 

• Struktur senyawa (ligand) 
 

3. Instalasi Aplikasi yang Dibutuhkan 
PLANTS tidak memiliki aplikasi untuk WINDOWS, maka hanya bisa dijalankan dengan menggunakan 
LINUX. Ada 2 macam aplikasi LINUX yang bisa digunakan, dimana tergantung dari Operating System 
(OS)-nya. Co-Pendrivelinux bagi Windows 32-bit, sedangkan untuk Windows 64-bit digunakan aplikasi 
Virtualbox. Namun pada protokol kali ini akan difokuskan pada aplikasi Virtualbox 

a. Instalasi VirtualBox 

No Prosedur Kerja Perhatian 

1. Klik 2 kali ikon VirtualBox, hingga keluar 
perintah seperti pada gambar. Klik “Next” > 
“Next” (direktori file= C:\Program 
Files\Oracle\VirtualBox) > “Next” > Install  
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2. Tampilan setelah proses instalasi, seperti 
gambar 

 
3. Kemudian muncul tampilan utama VirtualBox 

 
4. Klik New (berwarna biru), kemudian isi Name 

dengan “blangkon” dan ganti Type dengan 
Linux, maka Version akan otomatis menjadi 
Ubuntu 
Klik Next...... seterusnya. 
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5. Selanjutnya, klik Settings (warna orange), 
pilih menu Storage,  
kemudian hapus attachment blangkon.vdi 
(lingkaran),  
lalu ditambah atachment (Add Hard Disk) > 
Choose existing disk > pilih “Blangkon” yang 
sudah dipindahkan ke drive C:\Users\(nama 
user) > Ok. 

 
 

 
6. VirtualBox siap digunakan dan bisa mulai 

dioperasikan dengan mengklik “Start” 

 
 
Tampilan Home VirtualBox 
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b. Instalasi MarvinSketch 

No. Prosedur Kerja Perhatian 

1. Klik 2 kali ikon marvinbeans 

 

 
2. Klik “Next” .......dan seterusnya 

 
3. Saat selesai melakukan instalasi, maka di 

dekstop akan muncul ikon MarvinSketch. Klik 
ikon tersebut. 
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4. Maka akan muncul tampilan seperti pada 
gambar. MarvinSketch siap digunakan. 

 
 

4. Preparasi Protein 

No. Prosedur Kerja Perhatian 

1. Buka link rcsb.org, kemudian search kode 
protein yang ingin dicari (3pp0) 

 
2. Download file 3pp0.pdb, lihat gambar 

disamping 
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3. Buka YASARA (klik shortcut YAARA di 

dekstop). Load file 6COX.pdb ke YASARA 
dengan cara File > Load > PDB File.... cari 
direktori tempat menyimpan file tersebut, klik 
OK. 

 
4. Hapus bagian dari sistem yang tidak 

diperlukan (yang dibutuhkan hanya satu 
protein, termasuk air jika esensial, dan satu 
ligan). 

Pada tahap ini, lihat website diatas di bagian “Small 
Molecule” (Ligand). Disana memuat informasi 
mengenai ligan asli dari suatu protein 
 
 
 
 
 

03q merupakan ligan asli (native 
ligand) dari protein 3pp0 
 
 
 
 
 

 
Hanya digunakan satu chain saja, sehingga salah satu 
molekul dihapus, dengan cara: 
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Delete chain B (Edit > Delete > Molecule), pilih 
Sequence B, Name B, Belongs to or has All, dan klik 
Ok 

 
 
 

5. Tambahkan hidrogen ke dalam sistem 
dengan bantuan YASARA, sebab resolusi 
struktur kristal tidak mampu memprediksi 
keberadaan hidrogen  
(Edit > Add > Hydrogens to all) 

 
6. Simpan file sebagai YASARA Object  

(File > Save as > YASARA Object) 
→ simpan sebagai 3pp0.yob 
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7. Delete ligan asli (native ligand), sehingga 
hanya menyisakan protein target saja 
dengan pocket untuk docking  
(Edit > Delete > Residue).  
Pilih Name 03q, Belongs to or has All, klik Ok 

 
 
Atau dengan cara, klik molecule A yang mengandung 
ligan asli (nomor 2), klik kanan > Delete 
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8. Simpan hasil sebagai protein.mol2 
(File > Save as > Other file format) 
Object 3pp0 (diklik); File format mol2; 
Browse: C:\docking_plants; Name: 
protein.mol2 

 
9.  Koordinat pocket dapat diketahui dengan 

merujuk pada koordinat ligan 3D asli. Untuk 
itu hanya diperlukan file mol2 yang hanya 
berisi ligan asli 
a. File > New dan klik “Yes” 
b. File > Load > YASARA Object | Browse.... 

file 3pp0.yob yang disimpan di poin 5 
c. Edit > Delete > Residue; pilih Name 03q, 

Belongs to or has All, aktifkan opsi 
“Negate name” dan klik Ok 

d. Hasil disimpan sebagai ref_ligand.mol2 
(menggunakan prosedur seperti pada 
poin 8) 

 
 

Atau dengan cara, klik molecule A yang mengandung 
selain ligan asli (nomor 1 dan 3 atau kebalikan dengan 
prosedur poin 7), klik kanan > Delete 
 

 
 

Preparasi protein untuk docking sudah selesai. File protein.mol2 dan ref_ligand.mol2 sudah 
tersedia untuk simulasi docking menggunakan program PLANTS. Yang masih diperlukan adalah file 
ligan (dalam berbagai konformasi representative) dengan format .mol2 untuk didockingkan ke protein 
.mol2) 
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5. Preparasi Ligand 

No. Prosedur Kerja Perhatian 

1. Buka MarvinSketch. Dan gambarkan 
senyawa SC-558 di jendela MarvinSketch. 
Ada dua cara dalam menggambarkannya 
yaitu: 
a. File > Open … ref_ligand.mol2 (file 

hasil poin 8 di tahap preparasi protein). 
Structure > Clean 2D > Clean in 2D, 
atau .. 

b. Mengambar struktur secara manual 
 

 
2. Cek protonasi di pH 7,4 

(Tools > Protonation > Major Microspecies _ 
Klik “OK” di jendela yang baru terbuka) 

 
3. Jika muncul pertanyaan tentang lisensi, 

abaikan dulu (lisensi dapat diperoleh 
dengan login ke ChemAxon). Klik “OK” 
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4. Klik kanan di jendela yang memunculkan 
major species, pilih “Save as…”  
Simpan di C:\PLANTS sebagai 
ligand_2D.mrv 

 
5.  Tutup jendela MarvinSketch. Jangan lupa 

klik “No” saat ditanya untuk menyimpan 
sebelum menutup jendela MarvinSketch dan 
membuka jendela MarvinSketch yang baru. 

 

6. File > Open…ligand_2D.mrv  

7. Pencarian konformasi  
(Tools > Conformation > Conformers _ Klik 
“OK”) 
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8. Simpan hasil pencarian konformasi. Simpan 
file di jendela baru 
“Conformers” File > Save as… _ di 
C:\docking_plants dengan nama ligand dan 
tipe file .mol2 

 
9. Preparasi ligan sudah selesai. Jendela 

MarvinSketch dapat ditutup. 
 

 
6. Simulasi Docking 

a. Menggunakan VirtualBox 

No. Prosedur Kerja Perhatian 

1. Pindahkan semua hasil preparasi ke dalam 
flashdisk  

Total ada 9 file 
3pp0.pdb; 3pp0.yob; protein.mol2; ref_ligand.mol2; 
ligand.mol2; ligand_2D.mrv; PLANTS; PLANTS64; 
plantsconfig 

2. Buka VirtualBox, klik Start  

3. Ketika muncul tampilan Home seperti 
gambar disamping,  
Klik kanan pada ikon yang dilingkari, 
kemudian pilih USB/flasdick tempat file 
preparasi 
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4. Pindahkan semua file preparasi tersebut 
dari flashdisk ke folder “virtual” 

 
5.  Selanjutnya, klik logo Oracle VirtualBox 

(pojok kiri atas) > klik cari > ketik “terminal”, 
hingga muncul tampilan seperti pada 
gambar 
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6. Kemudian, mainkan arah ke atas atau ke 
bawah dengan urutan sebagai berikut 
chmod u+x PLANTS (enter) 
./PLANTS (enter) 
./PLANTS –mode bind ref_ligand.mol2 5 
protein.mol2 (enter) 
grep –Ev “# binding site definition” 
plantsconfig > temp_conf (enter) 
grep –Ev “# binding site_” temp_conf > 
temp_conf2 (enter) 
cat temp_conf2 bindingsite.def > 
plantsconfig (enter) 
./PLANTS –mode screen plantsconfig 
(enter) 
 
VirtualBox akan memproses simulasi 
docking tersebut untuk ke-sepeluh 
konformasi ligand yang sudah dipreparasi 
sebelumnya. 

Proses men-docking

 
 
 

7. Setelah selesai proses simulasi docking 
kesepuluh konformasi ligan, kemudian  
cd results/ (enter) 
more bestranking.csv 
 

 
 
Akan muncul tampilan sebagai berikut 
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8. Ligan dengan skor docking paling kecil 
(paling negatif) yang terdapat dalam folder 
results dipindahkan ke flashdisk 

 
 

 
9. Proses simulasi docking selesai, dilanjutkan 

dengan proses validasi docking 
 
 

 
7. Validasi Docking 

No. Prosedur Kerja Perhatian 

1. Jalankan YASARA.  
Load ref_ligand.mol2 dan file hasil docking 
yang telah disalin di flashdisk ke YASARA.  
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2. Hapus atom hydrogen  

(Edit > Delete > Hydrogens).  
 

 
 
 
 
 
 
 
 
 

3. Hitung RMSD pose 
hasil docking dengan referensi hasil 
eksperimen/struktur kristal. 
 
Analyze > RMSD of > Molecules … akan 
muncul jendela seperti berikut dua kali. 
Pada saat 
muncul pertama pilih sequence atas atau 
sequence dengan kolom 3 bernomor 1. 
Pada 
kemuculan kedua pilih sequence bawah 
atau sequence dengan kolom 3 bernomor 
2. Sementara 
Name dan Belongs to or has dibiarkan apa 
adanya. 
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4. Lalu akan muncul jendela seperti dibawah 
ini. Pastikan semua opsi unchecked kecuali 
opsi di bawah tulisan “Molecule”. 
 
Klik Ok 

 
5.  Akan muncul command line di bawah 

aplikasi YASARA, yang menunjukkan hasil 
RMSD  

6. Root mean square distances (RMSD) heavy 
atoms senyawa hasil docking dengan 
referensinya sebesar 0,7520 angstrom. 
Sebuah protokol diterima bila RMSD heavy 
atoms hasil docking dibandingkan dengan 
referensinya kurang dari 2.0 angstrom.  

 

 
8. Visualisasi 

No. Prosedur Kerja Perhatian 

1. Buka aplikasi YASARA 
Load > Other file format > ligand dengan 
skor docking terbaik > Ok 
Load > Other file format > protein.mol2 > Ok 
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2. Hapus atom hidrogen 

Edit > Delete > Hydrogens 

 
 
 
 

 
3. Gabungkan kedua objek tersebut, dengan 

cara 
Edit > Join > Object 
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4. Disimpan objek tersebut dengan format pdb 

file, dengan cara 
File > Save as > PDB file 

 
 

 
Objek sudah siap. 
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5.  Selanjutnya, buka aplikasi moe. Buka file 
pdb yang sudah dibuat. 
File > Open > PDB File (browse tempat 
diletakkan file pdb, c:/docking_plants/3pp0) 

 
 
Muncul tampilan sebagai berikut 

 
6. Kemudian, klik Hide > All Atoms 

 
 

7. Klik, Show > Ligand 
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8. Show > Pocket 

 
9. Klik Compute > Surface and Maps 

Klik Color > Pocket > Create > Isolate 
Klik Save as > dan diberi nama 3D.png 
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Visualisasi 3D 

10. Klik Compute > Ligand Interactions > Export 
Klik Save as > diberi nama 2D.jpg 
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Visualisasi 2D 

 
 
C.2. Molecular Docking menggunakan MOE 

1. Alat & Instrumen: 

• Laptop atau Komputer  

• Aplikasi MOE  
 

2. Bahan: 

• Protein target (kode protein dari PDB) 

• Struktur senyawa (ligand) dari situs https://pubchem.ncbi.nlm.nih.gov/ 
 

3. Pengantar 
MOE   → MOE Window 
DBV   → Database Viewer 
MOE | RHS  → Right Hand Side Button Bar (MOE Window) 

 
4. Preparasi Protein 

No. Prosedur Kerja Perhatian 

1. Buka rcsb.org, kemudian search kode 
protein yang ingin digunakan (misal 
3pp0) 

 

https://pubchem.ncbi.nlm.nih.gov/
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2. Download kode protein tersebut 

  
 

3. Buka aplikasi MOE 2010 (terletak 
pada folder bit i4w9) 

 
 

4. Buka file kode protein yang berformat 
.pdb (MOE | File | Open, kemudian 
ketikkan direktori tempat 
penyimpanan file tersebut).   
 
 

Jangan lupa klik CWD, supaya dalam pemanggilan file 
setelah itu tetap dalam folder yang kita maksud, klik Yes 

 
 
Klik 2 kali file pdb yang akan kita preparasi, kemudian klik 
OK 
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5. Untuk mengetahui ada berapa chain 
dalam satu kode protein tersebut 
(3pp0) dapat dibuka Sequence Editor 
(RHS | SEQ). Lakukan seleksi 
sehingga menyisakan satu chain yang 
akan digunakan. 

Dalam SEQ diatas, terlihat bahwa 3pp0 memiliki 2 chain. 

 
 
Hapus molekul yang tidak dibutuhkan (klik pada nomor 
molekul, kemudian klik SEQ | Edit | Delete Selected Chains | 
OK) 

 
 
Sehingga menyisakan satu chain yang berisi (1) susunan 
asam amino, (2) ligand native, (3) molekul air 

 
 

6. Tambahkan hidrogen dan muatan 
parsial ke dalam sistem menggunakan 
aplikasi Protonate3D (MOE | Compute 
| Protonate3D) 

Klik OK 
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Proses ini membutuhkan waktu beberapa detik. Progress 
report akan tertulis pada jendela MOE. Pesan di kiri atas 
jendela MOE akan hilang ketika proses kalkulasi telah 
selesai. 

 
 
Proses protonasi telah selesai 

 
 

7. Gambar molecular surface di sekitar 
binding site dari protein reseptor 
tersebut (MOE | Compute | Surfaces 
and Maps) 

Atur Color menjadi Constant dan Surface Color menjadi 
hijau terang. Geser TB (yang kanan) menjadi sekitar ± 75% 
(untuk meningkatkan transparansi permukaan/ molecular 
surface) 
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Kemudian klik Create untuk menggambar surface. Tekan 
Isolate untuk membuat sisi ikat (to render the binding site)  

 
 

8. Simpan dengan format .moe. (MOE | 
File | Save)  

Save as kode protein_complex.moe (misal 
3pp0_complex.moe), klik Save 

 
 

 
 
 
 
 
 



Hal. 29 dari  40 
 

 

 

CANCER CHEMOPREVENTION RESEARCH CENTER 
FAKULTAS FARMASI UGM 

 

Dokumen nomor   :  Tanggal :  

Mengganti nomor : - Tanggal : - 

 
5. Preparasi Ligand (Senyawa Uji)  

No. Petunjuk Kerja Perhatian 

1. Buka situs pencarian struktur senyawa 
melalui website 
(https://pubchem.ncbi.nlm.nih.gov/) 

 
 
Ketikkan nama senyawa uji (misal Hesperidin) pada kolom 
pencarian 

 
 

2. Unduh senyawa uji (hesperidin) 
tersebut dalam bentuk 3D dengan 
format SDF 

 

https://pubchem.ncbi.nlm.nih.gov/
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3. Buka file senyawa uji yang telah 
diunduh tersebut dalam aplikasi MOE 
(MOE | File | Open) 

 
Klik dua kali pada file tersebut atau klik Ok 
 
Setelah di-klik Ok, akan muncul jendela seperti di bawah 
ini. Pada Destination, klik Browse. Beri nama senyawa uji 
pada kolom yang ditunjuk arah panah (misal 
hesperidin.mdb). klik OK (1). Setelah itu klik OK (2) 
kembali 

 
 
Akan muncul tampilan seperti dibawah ini. Senyawa uji siap 
digunakan untuk docking. 

 
 
 
 

1 

2 
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6. Simulasi Docking 

No. Petunjuk Kerja Perhatian 

1. Buka file protein reseptor yang telah 
dipreparasi (MOE | File | Open | 
3pp0_complex.moe | OK) 

 
 

2. Simulasi docking dengan native ligand 
(03Q) dengan cara MOE | Compute | 
Simulations | Dock 

Atur nama output menjadi kode protein_ref_dock.mdb 
(misal 3pp0_ref_dock.mdb | ref merujuk kepada reference 
karena dalam proses men-docking native ligand) 
 
Sesuaikan format isian dengan yang telah terisi 
sebagaimana jendela di bawah ini. Klik Run. 

 
 
Dalam proses docking terlihat struktur senyawa yang 
menggeliat membentuk konformasi yang beraneka macam 
yang sesuai dengan native ligand – nya pada binding site 
reseptor tersebut 
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Proses docking selesai, ditunjukkan dengan munculnya 
tabel database pada jendela DBV yang berisi mol, mseq, S 
(skor docking), rmsd, rmsd_refine, E_conf, E_place, 
E_score1, E_refine seperti ditunjukkan oleh tabel dibawah 
ini. 
  

  
 
Hasil docking diatas diurutkan berdasarkan nilai S (skor 
docking) yang paling negatif dimana nilainya identik 
dengan E_refine. Sedangkan kolom rmsd menunjukkan 
pose senyawa yang ditautkan dibandingkan dengan native 
ligand (posisi ligan ko-kristal). Hasil RMSD juga menjadi 
penanda validitas metode (RMSD <2 bermakna metode 
valid untuk digunakan).  
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3. Bandingkan ligand hasil docking yang 
memiliki S terbaik (paling negatif) 
dengan native ligand menggunakan 
Database browser (DBV | File | 
Browse) 

Pilih konformasi senyawa yang memiliki S terbaik (nomor 
1). Klik Keep > Close. 

 
Ligand hasil docking akan muncul pada jendela MOE. 
 
Atur Color dan Stick pada RHS | System.  

 
 

4.  Lakukan visualisasi interaksi di antara 
kedua ligand tersebut dengan cara 
MOE | Compute | Ligand Interactions  

Atur kolom Receptor dan Ligand menjadi Overlay 
Complexes, kemudian klik Apply > Isolate. 

 
 
Simpan file 2D ini dengan cara klik Export > Browse, 
tuliskan nama file ref_2D.png. klik OK. 

Native ligand  

Ligand hasil 
docking 
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Hasil visualisasi interaksi 2D (native ligand) 

 
 
Simpan juga ligand interactions dengan format 3D yang 
muncul pada jendela MOE (MOE | File | Save). Ubah 
kolom Save menjadi Picture sehingga format menjadi 
.png. Beri nama ref_3D.png. Klik Save. 
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Hasil visualisasi interaksi 3D (native ligand) 

 
 

5. Simulasi docking kembali dengan 
senyawa uji (Hesperidin) dengan 
memanggil kembali protein reseptor 
yang telah dipreparasi sebelumnya 
(MOE | File | Open | 
3pp0_complex.moe). kemudian 
simulasi docking dilakukan dengan 
cara MOE | Compute | Simulations | 
Dock 

Atur nama output menjadi kode protein_senyawa 
uji_dock.mdb (misal 3pp0_hesperidin_dock.mdb) 
 
Sesuaikan format isian dengan yang telah terisi 
sebagaimana jendela di bawah ini. Bedanya dengan native 
ligand terletak pada kolom Ligand. Ubah menjadi MDB 
File dan pilih database senyawa uji yang telah dipreparasi 
sebelumnya (hesperidin.mdb). klik Run. 
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Tunggu sejenak hingga proses docking selesai. 
 
Proses Docking selesai 

 
 

6. Bandingkan ligand hasil docking yang 
memiliki S terbaik (paling negatif) 
dengan native ligand menggunakan 
Database browser (DBV | File | 
Browse) 

Pilih konformasi senyawa yang memiliki S terbaik (nomor 
1). Klik Keep > Close. 
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Ligand hasil docking akan muncul pada jendela MOE. 
 
Atur Color dan Stick pada RHS | System.  

 
 

7. Lakukan visualisasi interaksi di antara 
kedua ligand tersebut dengan cara 
MOE | Compute | Ligand Interactions  

Atur kolom Receptor dan Ligand menjadi Overlay 
Complexes, kemudian klik Apply > Isolate. 

 
 

Native ligand  

Ligand hasil 
docking 
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Simpan file 2D ini dengan cara klik Export > Browse, 
tuliskan nama file hesperidin.png. klik OK. 

  
 
Hasil visualisasi interaksi 2D (Hesperidin) 

 
 
Simpan juga ligand interactions dengan format 3D yang 
muncul pada jendela MOE (MOE | File | Save). Ubah 
kolom Save menjadi Picture sehingga format menjadi 
.png. Beri nama ref_3D.png. Klik Save. 
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Hasil visualisasi interaksi 3D (Hesperidin) 
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